Eltex vESBC

Кириллова Маргарита
Акименко Евгений (Новосибирск)
Алексеев Никита (Москва)
Бадер Дарья (Новосибирск)
Бекетов Максим (Новосибирск)
Браун Захар (Новосибирск)
Бринева Анна (Москва)
Бубенов Максим (Новосибирск)
Буйнич Алексей (Новосибирск)
Бурдюгова Татьяна (Москва)
Бурмистров Игорь (Москва)
Васильева Татьяна (Москва)
Дашкина Ксения (Новосибирск)
Дудоров Дмитрий (Москва)
Жигульская Екатерина (Москва)
Ильиных Никита (Новосибирск)
Камышников Григорий (Новосибирск)
Каночкин Виталий (Москва)
Кириллова Маргарита (Новосибирск)
Клюй Вячеслав (Москва)
Козлов Дмитрий (Новосибирск)
Кузьмин Максим (Москва)
Ларин Алексей (Москва)
Ломоносова Екатерина (Новосибирск)
Лысенко Алексей (Москва)
Макаревич Евгений (Новосибирск)
Монтоев Анатолий (Новосибирск)
Мосин Михаил (Новосибирск)
Муртазин Камиль (Казань)
Наполов Илья (Москва)
Передерин Сергей (Новосибирск)
Поддубный Владислав (Москва)
Пучков Александр (Москва)
Пчелинская Светлана (Москва)
Рекун Антон (Москва)
Репьюк Алексей (Новосибирск )
Самойлов Иван (Новосибирск)
Сидоренко Никита (Новосибирск)
Степанов Артем (Москва)
Сутоцких Илья (Москва)
Сытый Александр (Москва)
Трифонов Артем (Новосибирск)
Ударцев Евгений (Новосибирск)
Фадин Дмитрий (Москва)
Файзрахманов Марат (Москва)
Чердынцев Артём (Москва)
Шатуха Егор (Москва)
Шаяхметов Илья (Новосибирск)
Щербаков Максим (Москва)
Документация
Предыдущие версии
Программное обеспечение
Душевная тех. поддержка

Краткое техническое описание (Datasheet)

– Виртуальное (vESBC) и аппаратное (ESBC-3200) исполнение
– Защита бизнес-процессов
1
Применение
ESBC используется на границах IP-сетей:
– между сетями операторов связи;
– между сетью оператора и корпоративной сетью
клиента;
– между сетью оператора и публичной сетью.
Функциональные возможности
– Обеспечение безопасности сети оператора связи
– Трансляция публичных IP-адресов
– Гибкое распределение резервных маршрутов
– Поддержка SIP-абонентов
– Анализ и верификация SDP
– Гибкое распределение вызовов на основе правил
– Модификация SIP-заголовков с помощью регулярных
выражений PCRE
– Поддержка гибкой маршрутизации вызовов
– Маршрутизация на группу направлений с поддержкой
логики балансировки (RR и WRR)
– Поддержка динамического режима работы транков через
DNS, RADIUS
– Поддержка перемаршрутизации при неудачном вызове
(контроль по кодам ответов SIP)
– Поддержка обработки ответов 3XX для управления
перенаправлением вызовов
– Контроль доступности направлений по OPTIONS
– Контроль установленных сессий:
– по наличию RTP/RTCP
– с использованием таймеров сессии (RFC4028)
– Хранение и восстановление записей о зарегистрированных
абонентах в БД
– Транскодирование/проксирование медиа (аудио и видео)
– Поддержка WebRTC+ICE для браузерных приложений
– Поддержка QoS (назначение Diffserv) для SIP и RTP
– Запись биллинговой информации в CDR-файл, параллель-
ная запись CDR-файла на локальный носитель и удаленный
сервер (FTP, SFTP, SCP)
– Поддержка аутентификации:
– аутентификация регистраций абонентов через RАDIUS
– локальное хранение данных аутентификации
– регистрация транков в режиме клиента на
вышестоящей IP АТС
– Поддержка транзита ISUP (SIP-I/SIP-T)
– Поддержка туннелирования PPTP и L2TP over IPsec для
передачи SIP и медиатрафика
– Поддержка функции ротации номеров (Cg/CdPN) при
осуществлении исходящих вызовов
– Использование тегов сессии для повышения гибкости при
маршрутизации/модификации SIP-сообщений
– Управление параметром Expires для контроля абонентов и
защиты от перегрузок
– Поддержка механизмов управления регистрациями абонентов:
– принудительная разрегистрация;
– принудительная перерегистрация.
Обход NAT
Функция, необходимая для обеспечения прозрачности IP-сетей
для голосового и видеотрафика.
– поддержка режима nat-comedia
– поддержка Public-IP
– поддержка работы через удаленный STUN-сервер
– локальный STUN-сервер
– поддержка "sip.instance" и "reg-id" (RFC5626)
Безопасность
E обеспечивает защиту сети оператора от несанкциониро-SBC
ванного доступа. Инструментами для обеспечения безопаснос-
ти служат интеллектуальное управление доступом и скрытие
топологии сети. Использование шифрования сигнализации SIP и
медиапотоков обеспечивает конфиденциальность и безопас-
ность передаваемых данных.
– динамический брандмауэр
– защита от SIP-флуда
– защита от SIP-spoofing атак
– блокировка по AOR, User-Agent
– локировка по содержимому SIP-сообщения
– поддержка шифрования сигнализации (TLS)
и медиапотоков (SRTP SDES, DTLS-SRTP)
– реализован функционал выгрузки событий информационной
безопасности в сторонние SIEM-системы в режиме
реального времени
ESBC — компонент VoIP-сети, участвующий в процессе
обслуживания вызова в качестве пограничного контроллера
сессий. Устройство обеспечивает нормализацию сигнального
протокола, защиту сети оператора от несанкционированного
доступа и различных атак, сбор статистики.
vESBC
vESBC
vESBC
ESBC-3200
Беспроводная точка доступа WEP-3ax
Техническое описание
Пограничный контроллер сессий ESBC
1eltex.ru
1
Функциональные возможности
Контроль трафика
ESBC позволяет управлять количеством входящих и исходящих
SIP-запросов в зависимости от направления:
– управление количеством установленных сессий,
ограничение входящих/исходящих CPS, RPS
– поддержка дополнительных ограничений
(rps, regps, session pps и др.)
Сокрытие топологии сети
ESBC используется для предоставления доступа в операторскую
или корпоративную сеть из внешней недоверенной сети, обеспе-
чивая защиту коммерческих интересов компании.
Поддерживаются следующие механизмы:
– интеллектуальная трансляция IP-адресов для сигнального и
медиатрафика
– полноценный B2BUA для обеспечения требуемого уровня
изоляции сетей
Мониторинг
– Мониторинг устройства по SNMP, отправка SNMP-трапов
при авариях
– Просмотр информации о зарегистрированных абонентах
– Мониторинг состояния транков
– Построение SIP Call Flow Diagram
– Просмотр и управление установленными соединениями
– Просмотр и управление белым/черным списками
– Статистика CPS, RPS
– Статистика SIP-сообщений
– Утилита Sngrep
– Мониторинг параметров трафика (KPI):
– активные вызовы
– средняя длительность вызова (ACD)
– входящие/исходящие попытки вызова
– количество зарегистрированных абонентов/контактов
Протоколы сигнализации
– SIP
Функциональность протокола SIP
– RFC-3261
– RFC-3264 (Offer/Answer)
– RFC-3311 (Update Method)
– RFC-4566 (SDP)
– RFC-1889 (RTP)
– RFC-2833 (Telephone Event)
– RFC-3515 (Refer Method)
– RFC-3265 (Subscribe)
– RFC-6086 (INFO Method)
– RFC 7118 (WebSocket)
– RFC 8445 (ICE) кроме STUN/TURN
– RFC 5768 (ICE SIP)
– RFC 8839 (SDP ICE)
– B2BUA peering
– RFC 4028
– RFC 5168
– RFC 3489 (Classic STUN)
– RFC 8489 (STUN)
– RFC 5626
Медиапротоколы
– RTP
– RTCP
– SRTP (SDES, DTLS)
Транспортные протоколы
– TCP
– UDP
– TCP/UDP interworking
– TLS
– WS/WSS
Сетевые протоколы
– IPv4
1
– IPv6
Поддерживаемые видеокодеки (в режиме
транскодирования)
– H.263-1998
– H.264
– VP8
– VP9
Резервирование
Применение схемы кластерного резервирования и дубли-
рованных источников электропитания обеспечивает полно-
ценное резервирование:
– отказоустойчивый кластер в режиме облегченного резерва
по схеме 1+1
– простота администрирования и интеграции: синхронизация
конфигураций, времени, версий; Zero Touch Provisioning
(ZTP)
Безопасность
– Защита от DoS
– Защита от VoIP-атак
Передача факса
– T.38
– G.711
Поддерживаемые аудиокодеки (в режиме
транскодирования)
– G.711 (a-law, μ-law), G.729, G.722, G.726, iLBC, opus, speex,
AMR, GSM, L16-mono
Управление
– MML-консоль (SSH/Telnet)
– Web-интерфейс²
– Выделенный порт управления (OOB) 10/100/1000BASE-T (RJ-45)
(только для ESBC-3200)
Лицензирование
– Виртуальное решение (vESBC) лицензируется с использованием
ELM (Eltex Licence Manager)
– Аппаратное решение (ESBC-3200) лицензируется с использованием
ELM или файлом лицензии
Беспроводная точка доступа WEP-3ax
Техническое описание
Пограничный контроллер сессий ESBC
¹ Не поддерживается в текущей версии ПО.
² В разработке. В текущей версии ПО доступны не все функции.
1
1eltex.ru
2
Функциональные возможности (продолжение)
Технические характеристики ESBC-3200
Интерфейсы
1000BASE-X/10GBASE-R/25GBASE-R
12
Console RS-232 (RJ-45)
1
OOB
1
USB 2.0
1
Слот для microSD-карт
1
Количество CPU
CPU
24
Физические характеристики и условия окружающей среды
RAM
24 ГБ
Flash-память
8 ГБ eMMC
Максимальная потребляемая мощность
118 Вт
Питание
100–240 В АС, 50–60 Гц;
36–72 В DC
До двух источников питания с возможностью горячей замены
Интервал рабочих температур
От -10 до +45 °С
Интервал температуры хранения
От -40 до +70 °С
Относительная влажность при эксплуатации
Не более 80 %
Относительная влажность при хранении
От 10 до 95 %
Габариты (Ш × В × Г)
430 × 44 × 330 мм
Масса
5,3 кг
Срок службы
Не менее 15 лет
¹ Приведенные требования позволяют произвести установку vESBC и первичный запуск с базовой настройкой.
Процессор
Архитектура x86-64, тактовая частота не менее 1,8 ГГц
Поддержка набора инструкций MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2
(поколение процессоров Intel Nehalem или AMD Barcelona CPU или выше)
Оперативная память
Не менее 3 ГБ
Дисковое пространство
Не менее 2 ГБ
Гипервизоры (указаны минимальные версии)
VirtualBox 6.0, ESXi 6.7.0, QEMU/KVM 2.6.2, Proxmox 8.1.4,
GNS3 2.2.53, EVE-NG 6.2.0, PNETLab 4.2.10, Xen 4.16, zVirt 5.0
Поддерживаемые I/O
Эмуляция:
Intel E1000, Intel E1000E,
VMXNET2, VMXNET3
Паравиртуализация:
VirtIO
PCI Pass-through:
Intel XL710 Ethernet Controller (2x40/1x40/4x10/2x20/2x10/1x10),
Intel X722 Ethernet Controller (2x10/4x10),
RTL8169 PCI Gigabit Ethernet Controller,
RTL810xE PCI Express Fast Ethernet controller,
RTL8110SC/8169SC Gigabit Ethernet,
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller,
RTL8100/8101L/8139 PCI Fast Ethernet Adapter
1
Минимальные системные требования для виртуального решения vESBC
Беспроводная точка доступа WEP-3ax
Техническое описание
Пограничный контроллер сессий ESBC
1
3
eltex.ru
¹ Приведенные требования позволяют произвести установку vESBC и первичный запуск с базовой настройкой.
3
¹ Характеристики сервера: CPU — 2 x Intel(R) Xeon(R) Gold 6230 CPU @ 2.10GHz, 64 GB RAM, NIC — Intel X710 for 10GbE SFP+.
Характеристики виртуальной машины: 75 CPU, 32 GB RAM, PCI Pass-through.
Режим работы
vESBC¹
ESBC-3200
Проксирование с использованием кодека G711a
до 18500
до 6000
Транскодирование G711a <---> G729
до 2000
до 280
Проксирование с использованием кодека G711a
и преобразованием RTP <---> SRTP (SDES)
до 14000
до 5000
Проксирование с использованием кодека G711a
до 950
до 350
Транскодирование G711a <---> G729
до 950
до 200
Проксирование с использованием кодека G711a
и преобразованием RTP <---> SRTP (SDES)
до 950
до 350
Производительность vESBC и ESBC-3200
Беспроводная точка доступа WEP-3ax
Техническое описание
Пограничный контроллер сессий ESBC
1eltex.ru
4
ESBC
Локальная сеть 1 Локальная сеть 3
Локальная сеть 2
Публичная
сеть ТфОП
SMG-1016M Q.931
SIP
ESBC
ECSS-10
Softswitch
ECSS-10
Softswitch
ECSS-10
Softswitch
S7S
Схемы применения
Межоператорское взаимодействие
ESBC
Схемы применения (продолжение)
1
456
7
0 #
8 9
*
2 3
1
456
7
0 #
8 9
*
2 3
1
456
7
0 #
8 9
*
2 3
1
456
7
0 #
8 9
*
2 3
TAU-16
Абонентский
шлюз
ECSS-10
Softswitch
Аналоговый
телефон
IP-телефон IP-телефон
IP-телефон
IP-телефон
IP-телефон
Аналоговый
телефон
TAU-8
Абонентский
шлюз
Аналоговый
телефон
Аналоговый
телефон
1
456
7
0 #
8 9
*
2 3
ESBC
Публичная
сеть
SIP
SIP/WebRTC
SIP
SIP
Офис 1
Офис 2
Офис 3
Предоставление услуги «Виртуальная АТС»
Elph Android/iOs
Мобильный клиент
Elph Desktop
Браузерный клиент
SIP WebRTC
Беспроводная точка доступа WEP-3ax
Техническое описание
Пограничный контроллер сессий ESBC
1eltex.ru
5
Наименование
Описание
vESBC
Программный пограничный контроллер сессий vESBC.
ESBC-3200
Пограничный контроллер сессий ESBC-3200.
Опции для пограничного контроллера сессий ESBC¹
ESBC-CC-10
Активация 10 одновременных вызовов.
ESBC-CC-50
Активация 50 одновременных вызовов.
ESBC-CC-100
Активация 100 одновременных вызовов.
ESBC-CC-500
Активация 500 одновременных вызовов.
ESBC-CC-5000
Активация 5000 одновременных вызовов.
ESBC-CPS-20
Активация поддержки интенсивности входящей нагрузки 20 CPS.
ESBC-CPS-40
Активация поддержки интенсивности входящей нагрузки 40 CPS.
ESBC-CPS-60
Активация поддержки интенсивности входящей нагрузки 60 CPS.
ESBC-CPS-80
Активация поддержки интенсивности входящей нагрузки 80 CPS.
ESBC-CPS-100
Активация поддержки интенсивности входящей нагрузки 100 CPS.
IPS
Активация функционала IPS/IDS.
Информация для заказа
Устройство
Блок питания AC
Блок питания DC
ESBC-3200
PM160-220/12
PM160-48/12
2
Блоки питания
¹ Опции ESBC-CC и ESBC-CPS обязательны для включения в заказ.
² Определяется при заказе.
Беспроводная точка доступа WEP-3ax
Техническое описание
Пограничный контроллер сессий ESBC
2
6
Сделать заказ
Предприятие «ЭЛТЕКС» — ведущий российский разработчик и произ-
водитель коммуникационного оборудования с 30-летней историей.
Комплексность решений и возможность их бесшовной интеграции
в инфраструктуру Заказчика — приоритетное направление развития
компании.
О компании Eltex
+7 (383) 274 10 01
+7 (383) 274 48 48
eltex@eltex.ru eltex.ru
eltex.ru